Download Navigation
 
Home | Support | Tech Notes | Can I use my MOTU hardware with Mac OS X v10.6 Snow Leopard? Does my software work with Snow Leopard?
Document Actions

Can I use my MOTU hardware with Mac OS X v10.6 Snow Leopard? Does my software work with Snow Leopard?

Hardware

We have drivers for our FireWire/USB2 audio interfaces, FireWire video interfaces, PCI-424 audio interfaces, and USB MIDI interfaces to operate under Mac OS X version 10.6 Snow Leopard. The minimum drivers required under Mac OS X v10.6 are:

  • FireWire/USB2 Audio 1.4.23
  • PCI-424 Audio 1.2.2
  • FireWire Video 1.1.2
  • PCI Video 1.0.0
  • USB MIDI 1.4.23

Software

The following versions or later are required for Mac OS X v10.6 support:

  • Digital Performer 6.02
  • AudioDesk 3.0
  • MX4 2.2
  • MachFive 2.0.2
  • Ethno Instrument 2.0
  • Symphonic Instrument 1.1.3
  • Electric Keys 1.0.1
  • BPM 1.0.4
  • Volta 1.0.4

To download the latest MOTU updates, go to our Mac downloads area. To download the latest iLok drivers from PACE (required for all iLok-authorized software), go to the PACE driver download page.

My Account