Download Navigation
 
Home | Support | Tech Notes | Can I use my MOTU hardware with Windows 7? Does my software work with Windows 7?
Document Actions

Can I use my MOTU hardware with Windows 7? Does my software work with Windows 7?

Hardware

We have drivers for our FireWire/USB2 audio interfaces, PCI-424 audio interfaces, and USB MIDI interfaces to operate under Windows 7. The minimum drivers required under Windows 7 are:

  • FireWire/USB2 Audio 3.6.8.1416
  • FireWire Video 4.0.4.1723
  • PCI-424 Audio 1.6.9.2
  • USB MIDI 1.0.1.2

Software

The following versions or later are required for Windows 7 support:

  • BPM 1.0.5
  • Electric Keys 1.0.2
  • Ethno Instrument 2.0

Compatibility testing for MachFive and Symphonic Instrument with Windows 7 is on-going; please check back at motu.com for announcements.

To download the latest MOTU updates, go to our Windows downloads area. To download the latest iLok drivers from PACE (required for all iLok-authorized software), go to the PACE driver download page.

My Account